Jump to content
Sign in to follow this  
the_pilot_cat

Puma HC1 -Taking damage when landing, seems a bit excessive.

Recommended Posts

I will preface this by saying I only have a manual for the SA-330J, not the Puma HC.1, so it might just be that the 330J is more durable irl, if so feel free to tell me I'm a fucking retard.

I've done some flying with the Puma now, and keep encountering the same issue, when doing a standard clear area landing (in this case on a runway because I'm still learning the heli), I keep ending up in a spectacular fireball that wouldn't look entirely wrong in a Michael Bay movie. 

The landings have all been almost exactly as outlined on pages 66 and 67 of this SA-330J manual http://www.avialogs.com/viewer/avialogs-documentviewer.php?id=1960 , which I understand is for a different variant of the aircraft. AFM settings in game are as follows:
AFM: ON
Show Gauges: ON
Rough Landing: OFF
Wind Effects: ON
Auto Trim: OFF
Stress Damage: ON

The wheel brakes are off, landing gear extended, and descent rate at touchdown is minimal. I see no reason for the aircraft to do it's best impression of an IED at any stage.

Damage sustained during landing in a rough timeline is as follows (all times from wheels touching down, in seconds

+0.2 ENG Red
+0.5 ENG, SLG, MROT Red
+0.7 ENG, SLG, MROT, ATRQ, HULL, INST Red, Smoke coming out of exhausts on both sides
+1.3 Fire starts coming out of both exhausts
+1.9 Aircraft explodes and goes into destroyed state.

Mods loaded are Puma HC.1, RKSL Airfield Support Tug, Lesh's Towing mod.

Addendum: Testing reveals that the speed at which the aircraft starts taking damage while taxiing/doing a rolling takeoff/landing is 23kt.


View full bug

Share this post


Link to post
Share on other sites

Ok I've just pushed a new version onto Steam and this website.  It fixes a problem with interacting (and taking damage from them) with Physx and Roadway object.  Try that and let me know how you go on.

 

Share this post


Link to post
Share on other sites
19 hours ago, the_pilot_cat said:

Thanks. It now behaves as expected, love it when mod devs listen to their tickets, that's kinda rare sadly.

Well I broke it :)  I should fix it :P

Im glad it works and thanks for feeding back.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×